Data delay for PowerTrack EU

Incident Report for Stem

Resolved

This incident has been resolved.
Posted Aug 08, 2026 - 23:13 PDT

Monitoring

A fix has been implemented. We are now processing through the backlog of data which has accumulated during the outage. We expect the data backlog to be processed within the next few hours.
Posted Aug 08, 2026 - 22:46 PDT

Identified

The EU PowerTrack environment is currently experiencing a major outage. We have identified the issue and are working with our service providers to implement a resolution. We thank you for your patience as we work to bring our systems back up.
Posted Aug 08, 2026 - 21:35 PDT

Investigating

Customers in the EU may experience data delays. We are actively investigating the issue.
Posted Aug 08, 2026 - 19:36 PDT
This incident affected: PowerTrack EU (REST API, SOAP API, User Interface (HTML), Public Display Endpoints, PVGuard to Powertrack Data Pipeline, Data Ingest).