Unexpected Alert Activation

Incident Report for AlsoEnergy

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 20:31 PDT

Identified

We've identified a condition in some alert configurations resulting in unexpected activation. A maintenance event is currently being scheduled to address the condition.
Posted Oct 08, 2025 - 09:52 PDT
This incident affected: PowerTrack US (Alerts - Device to Server Communications) and PowerTrack EU (Alerts - Device to Server Communications).