Data Ingest Delay

Incident Report for AlsoEnergy

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 13:41 PDT

Monitoring

All systems are operational and we are now waiting for data ingestion to catch up.
Posted Sep 22, 2025 - 11:37 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2025 - 09:01 PDT

Investigating

We are experiencing data ingest delays. We are currently investigating the issue and will provide updates soon.
Posted Sep 22, 2025 - 07:37 PDT
This incident affected: PowerTrack US (Data Ingest).