Delays in processing certain sites

Incident Report for AlsoEnergy

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 14:13 PDT

Monitoring

Fixes were implemented and all sites reducing backlogs. Expect some latency during this phase. We are continuing to monitor as we recover into normal operations.
Posted Jan 23, 2025 - 13:46 PST

Identified

The scheduled maintenance has been successfully completed. However, please note that there may still be a brief delay in data ingestion for a short period of time.
Thank you for your patience
Posted Jan 22, 2025 - 22:24 PST
This incident affected: PowerTrack US (PL1K Data Processing).