We are continuing to process through the large backlog of data caused by the AWS outage. Some customers may experience data delays up to several hours until we finish processing the entirety of the data.
Posted Oct 21, 2025 - 00:26 PDT
Monitoring
Data ingest has begun recovery. We are now processing through the significant backlog of data.
Posted Oct 20, 2025 - 14:00 PDT
Identified
Data ingest continues to be critically impacted. However, we are seeing initial signs of recovery of critical AWS services. We appreciate everyone's patience as we continue to navigate this global outage.
Posted Oct 20, 2025 - 12:21 PDT
Update
Critical AWS services required for data ingestion to function are still down. We continue to monitor this outage and will provide update as we learn more.
Posted Oct 20, 2025 - 06:22 PDT
Investigating
Data Ingestion is currently severely impacted due to regional outages at AWS. We are closely monitoring the situation and will provide updates as we learn more.
Posted Oct 20, 2025 - 01:31 PDT
This incident affected: PowerTrack US (Data Ingest) and LocusNOC (Data Ingests).