PTWeb Reporting degraded performance

Incident Report for Stem

Resolved

All reporting issues have been resolved.
Posted Apr 21, 2025 - 14:29 PDT

Investigating

Report Queue is currently very high. Any user who tries to generate a report will have the request pending in a queue, and it will be completed once the queue is cleared.
Posted Apr 21, 2025 - 11:11 PDT