PowerTrack Inaccessible

Incident Report for Stem

Resolved

This incident has been resolved.
Posted Sep 26, 2026 - 12:21 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2026 - 08:39 PDT

Investigating

The PowerTrack website is currently inaccessible. We are aware of the issue and are working to resolve it.
Posted Sep 26, 2026 - 08:08 PDT
This incident affected: PowerTrack US (User Interface (HTML), Public Display Endpoints).