Maintenance has been completed. The data backlog will be resolved shortly.
Posted Oct 06, 2025 - 20:53 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 06, 2025 - 19:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 06, 2025 - 09:58 PDT
Scheduled
Please be advised of scheduled infrastructure upgrades on Mon., Oct. 6 to enhance PowerTrack's performance and reliability.
When: Mon., Oct. 6: • 7:00 p.m. PST (Pacific) • 8:00 p.m. MST (Mountain) • 9:00 p.m. CST (Central) • 10:00 p.m. EST (Eastern) Tues., Oct. 7: • 5:00 a.m. CET (Central European) • 11:00 a.m. JST (Japan) What to Expect: • Data ingestion delays: Up to 30 minutes • Brief service interruptions: You may be logged off and experience intermittent access issues
Posted Oct 06, 2025 - 09:54 PDT
This scheduled maintenance affected: PowerTrack US (Data Ingest).